Back to overview
Downtime

Network Outage - Amsterdam

May 12, 2026 at 1:37am UTC
Affected services
BUDGET VPS - AMS - 01
EXTREME PERFORMANCE VPS - AMS - 01
Game - AMS - 01
Router - Amsterdam (Core)

Resolved
May 12, 2026 at 2:43am UTC

The incident has been resolved.

Updated
May 12, 2026 at 1:38am UTC

Update: We've received news that their Amsterdam router completely died in Nikhef and that a NOC engineer has been send on-route to replace the router. This might take a while unfortunately and can expect issues for 1-2 hours.

Sorry for the disruption, this is unfortunately out of our hands as failover didn't kick in automatically.

Created
May 12, 2026 at 1:37am UTC

We're currently experiencing a partial network related outage in Amsterdam. Upstream has been notified, and they already identified the problem.

We're waiting for a fix to be implemented asap.